Информатика, вопрос задал ИринкаФ , 9 лет назад

Паскаль, ребятки? Кто тут гений информатики? Помогите, пожалуйста!!! Написать программу и блок-схему
Дан массив из 10 целых чисел, заполненный генератором случайных чисел. Найти минимальный элемент в массиве и подсчитать количество таких элементов в массиве.

Ответы на вопрос

Ответил 068419084
0
program p12;
type tab=array[1..10] of integer;
var t:tab;
i,k,min:integer;
begin
min:=100;
for i:=1 to 10 do
t[i]:=random(10);
for i:=1 to 10 do
if(t[i]<min) then min:=t[i];
for i:=1 to 10 do
if(t[i]=min) then k:=k+1;
write('массив: ');
for i:=1 to 10 do
write(t[i],' ');
writeln;
writeln('Меньшее число ',min);
write('Количество меньших чисел ',k);
end.
Новые вопросы