Информатика, вопрос задал kav9987 , 7 лет назад

паскаль прошу очень важно)Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – максимальное число, кратное 4. Пример работы программы:

Ответы на вопрос

Ответил mesmerizingbutterfly
0

Ответ:

Объяснение:

var A:array [0..30000] of longint;

n,i,max:integer;

begin

read (n);

for i:=1 to n do begin

 A[i]:=random (30000);

 write (A[i],' ');

 end;

max:=A[1];

for i:=1 to n do begin

 if (A[i]>max) and (A[i] mod 4=0) then

 max:=A[i];

 end;

writeln ('Максимальное число кратное 4= ', max);

end.

Если тебе нужно вводить числа с клавиатуры замени строчку

A[i]:=random (30000);  на read (A[i]);

Новые вопросы