ПАСКАЛЬ ПОМОГИТЕ СРОЧНО ПОЖАЛУЙСТА
Дан массив состоящий из 10 целых случайных чисел напишите программу количества повторений заданного элемента
nastikots:
Элемент задаётся после вывода массива на экран?
Ответы на вопрос
Ответил nastikots
0
Ответ:
program z1;
var a:array[1..10]of integer;
i,n,k:integer;
begin
write('Массив: ');
for i:= 1 to 10 do
begin
a[i]:= random(10);
write(a[i]:3)
end;
writeln;
write('n = ');
readln (n);
k:=0;
for i:= 1 to 10 do
if a[i]= n then k:=k+1;
write ('Количества повторений элемента ',n,' равно ',k)
end.
Объяснение:
Выводим массив из случайных чисел на экран
Задаём значение элемента, количество повторений которого надо посчитать
Считаем количество повторений
Выводим на экран количество повторений
Новые вопросы
Другие предметы,
2 года назад
География,
2 года назад