Информатика, вопрос задал Kamil1312 , 6 лет назад

Паскаль. Помогите, пожалуйста. Напишите программу, которая в последовательности целых чисел определяет сумму двух наибольших и сумму двух наименьших.

Ответы на вопрос

Ответил EgorPIVO
0

max, premax, min, premin = 0, 0, 1, 1

str = input('Введите ряд чисел через пробел: ').split(' ')

for i in str:

 if not i.isdigit():

   print('Вводите только числа через 1 пробел!')

   break

 else:

   if int(i) > max:

     premax = max

     max = int(i)

   if int(i) < min:

     premin = min

     min = int(i)

print(f'Сумма двух наибольших: {max + premax} ({max} + {premax})')

print(f'Сумма двух наименьших: {min + premin} ({min} + {premin})')

Новые вопросы