Информатика, вопрос задал R8A , 8 лет назад

Паскаль
Помогите доделать задачу

Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.

Входные данные
Программа получает на вход три натуральных числа: x, p, y.

Выходные данные
Программа должна вывести одно целое число.
program u1;
var
x, p ,s,n: integer;
y:real;
begin
read(x);
read(p);
read(y);
s:=0;
s:= x +(x*p)div 100;
n:= 1;
while (s < y) do
begin
s := s +((s*p)div 100);
n:= n + 1;
end;
writeln (n);
readln;
end.

Здесь где-то есть недоработка.

Ответы на вопрос

Ответил petyaGavrikov
0
program u1;
var 
x, p ,y, s, n: integer;
begin
readln(x,p,y); 
s:=x;
n:= 0; 
while (s < y) do 
begin 
s := s+trunc((s*p)/100); 
n:= n+1; 
end; 
writeln(n);
end.

Пример:
100 10 500
18
Новые вопросы