Паскаль.
Нужно написать программу, которая высчитывает среднею температуру, максимальную и минимальную температуру за месяц.
Вот, пытался написать сам, не получается:
program PoGoda;
uses crt;
var
x, n, t : integer;
max, min, imax, imin : integer;
const z=5;
begin
for x := 0 to z do;
x :=1;
while (x < z+1)do
begin {Создаем массив}
while (x > z) do
writeln;
write ('Какая температура была в ');
write ( x);
write (' день? ');
readln (t);
inc (x);
end;
max:= t[x];
for x:=0 to z do
if max
begin
max:=t;
imax:=x
end
else
if min>t then
begin
min:=t;
imin:=x
end;
writeln;
writeln('Максимальное значение ',max);
writeln('В какой день месяца было максимальное значение ',imax);
writeln('Минимальное значение ',min);
writeln('В какой день месяца было минимальное значение ',imin);
readkey;
end.
Ответы на вопрос
Ответил Andrey05
0
Ответил Аноним
0
Спасибо, но нужно, чтобы пользователь сам вводил значение температуры.
Ответил Andrey05
0
вместо этого a[i]:=random (100)-50; напишите readln (a[i]);
Ответил Аноним
0
Спасибо, все работает
Новые вопросы
Алгебра,
2 года назад
Русский язык,
2 года назад
Химия,
9 лет назад
Экономика,
9 лет назад
Математика,
10 лет назад
География,
10 лет назад