паскаль
Найти среднее арифметическое нечетных цифр числа. Если таких цифр нет, вывести NO
Входные данные
Целое число
Выходные данные
Среднее арифметическое с точностью до 2-х знаков после запятой
Ответы на вопрос
Ответил maxtimtim
0
Ответ:
begin
writeln('Введите число: '); var n:=ReadInteger;
var s:=IntToStr(n); var k:=0; var sum:=0;
for var i:=1 to length(s) do
if StrToInt(s[i]) mod 2=0 then begin
sum:=sum+StrToInt(s[i]); k:=k+1;
end;
if k=0 then writeln('Чётных чисел нет') else
writeln('Среднее арифметическое чётных чисел = ',sum/k);
end.
Новые вопросы