Паскаль
Напишите программу, которая заполняет квадратную матрицу случайными числами в
интервале [10,99], и находит максимальный и минимальный элементы в матрице и их
индексы
Ответы на вопрос
Ответил Levrat
13
var a:array [1..10, 1..10] of integer;
i, j, max, min, imin, imax, jmin, jmax:integer;
begin
imax:=0; imin:=0; jmax:=0; jmin:=0;
max:=-maxint; min:=maxint;
for i:=1 to 10 do
begin
for j:=1 to 10 do
begin
a[i,j]:=random(89)+10;
write(a[i,j],' ');
if a[i,j]<min then
begin
min:=a[i,j];
imin:=i;
jmin:=j;
end;
if a[i,j]>max then
begin
max:=a[i,j];
imax:=i;
jmax:=j;
end;
end;
writeln;
end;
writeln;
writeln('Максимальный элемент:',max);
writeln('Его индекс ',imax,' ',jmax);
writeln('Минимальный элемент:',min);
writeln('Его индекс ',imin,' ',jmin);
end.
i, j, max, min, imin, imax, jmin, jmax:integer;
begin
imax:=0; imin:=0; jmax:=0; jmin:=0;
max:=-maxint; min:=maxint;
for i:=1 to 10 do
begin
for j:=1 to 10 do
begin
a[i,j]:=random(89)+10;
write(a[i,j],' ');
if a[i,j]<min then
begin
min:=a[i,j];
imin:=i;
jmin:=j;
end;
if a[i,j]>max then
begin
max:=a[i,j];
imax:=i;
jmax:=j;
end;
end;
writeln;
end;
writeln;
writeln('Максимальный элемент:',max);
writeln('Его индекс ',imax,' ',jmax);
writeln('Минимальный элемент:',min);
writeln('Его индекс ',imin,' ',jmin);
end.
Новые вопросы
Русский язык,
2 года назад
Английский язык,
2 года назад
Литература,
2 года назад
Химия,
7 лет назад