Информатика, вопрос задал kekich33 , 6 лет назад

ПАСКАЛЬ!! Напишите программу, которая в символьной строке заменяет все нули на единицы и наоборот. Остальные символы не должны измениться. Пример: Введите строку : 10a01Bx101 Ос Инверсия: 01a1 ОВхо101с​

Ответы на вопрос

Ответил valgrisa
0

Ответ:

program z;

var s:string;

i:integer;

begin

read (s);

for i:=1 to length(s) do

if s[i]='1' then s[i]:='0'

else if s[i]='0' then s[i]:='1';

write(s)

end.

Объяснение:

использовано:

цикл со счётчиком (length - количество символов в строке)

и

полный условный оператор с вложеным неполным условным оператором (if условие 1 then действие 1 else if условие 2 then действие 2)

Новые вопросы