Информатика, вопрос задал kisa1710 , 8 лет назад

Паскаль. Напишите программу, которая по последней цифре числа определяет последнюю цифру квадрата этого числа

Ответы на вопрос

Ответил Аноним
0
var a, b: longint;
begin
write ('введите число -> ');
readln (a);
a:=a mod 10;
b:=(a*a) mod 10;
writeln ('последняя цифра квадрата числа -> ',b);
end.
Ответил UniPie
0
var i: Integer;
begin
 write('Число: ');
 readLn(i);
 i := i mod 10;
 writeLn('Цифра квадрата = ',
 sqr(i) mod 10);
end.
Новые вопросы