(Паскаль) Напишите программу, которая для любого двухзначного числа выводит сумму его цифр.
Ответы на вопрос
Ответил Аноним
2
var a, x, s, i: integer;
begin
writeln('Введите целое число');
readln( a );
x:=a;
s:=0;
while ( x<>0 ) do
begin
s := s + (x mod 10);
x := x div 10;
end;
writeln( 'Сумма цифр числа ',a,' = ', s );
end.
Новые вопросы
Английский язык,
1 год назад
Математика,
1 год назад
Қазақ тiлi,
1 год назад
Математика,
7 лет назад