Информатика, вопрос задал katyaaa12 , 8 лет назад

ПАСКАЛЬ. Напишите программу для решения квадратного уравнения

Ответы на вопрос

Ответил pokemanbr
0
program kv;
var
   a,b,c,d:real;
begin
   write('Введите a,b и c: ');
   read(a,b,c);
   d:=sqr(b)-4*a*c;
   if(d<0) then writeln('Корней нет')
      else if(d=0) then writeln('Корень равен ',(-b/(2*a)))
         else writeln('Первый корень равен ',((-b+sqrt(d))/(2*a)),' Второй корень равен ',((-b-sqrt(d))/(2*a)));
end.
 
Ответил Аноним
0
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,c):=ReadReal3('Введите через пробел a,b,c:');
  var d:=b*b-4*a*c;
  if d<0 then Writeln('Нет действительных корней')
  else
    if d=0 then Writeln('Единственный корень ',-b/2/a)
    else begin
      d:=Sqrt(d);
      Writeln('Два корня: ',(-b-d)/2/a,' ',(-b+d)/2/a)
      end
end.

Пример
Введите через пробел a,b,c: 2.6 -3.1 0.15
Два корня: 0.0505284246495728 1.14177926765812
Новые вопросы