Информатика, вопрос задал Soffi7bayard , 7 лет назад

ПАСКАЛЬ. Напишите программу для получения квадратной матрицы порядка n* n.

Ответы на вопрос

Ответил angryfukse
0

PascalABC.NET

var

a:array [,] of integer;

j, i, n: integer;

begin

readln(n);

SetLength(a, n, n);

writeln('Сгенерированная матрица: ');

for i:= 0 to n-1 do

begin

for j:=0 to n-1 do

begin

a[i, j]:=random(100);

write(a[i, j]:3);

end;

writeln();

end;

end.

Ответил Soffi7bayard
0
Да что ж такое. Пишет, что в строчке a:array [,] of integer; синтаксическая ошибка, выделяя запятую.
Ответил Soffi7bayard
0
То есть в запятой ошибка?
Ответил angryfukse
0
Запятая означает, что массив двумерный
Ответил angryfukse
0
В каком компиляторе ошибка выдается?
Новые вопросы