Информатика, вопрос задал lzgrl666 , 7 лет назад

паскаль. написать программу СРЕДИ ЧИСЕЛ ЕСТЬ ОТРИЦАТЕЛЬНЫЕ?используя одну переменную (х) и цикл if-else (для х должно быть 4 числа использовать for нельзя)

Ответы на вопрос

Ответил Puz1koO
0

var

 x,i:integer;

 flag:boolean;

begin

 i:=0;

 repeat

   readln(x);

   if x<0 then

     flag:=true;

   inc(i);

 until i=4;

 writeln(flag);

end.


lzgrl666: если число разные (положительные и отрицательные) ответ неправильный
Puz1koO: Если среди введённых чисел есть отрицательное - программа выведет true, иначе false. Решение верно для вашего условия. Корректнее укажите условие
lzgrl666: если условие звучит СРЕДИ ЧИСЕЛ НЕТ ОТРИЦАТЕЛЬНЫХ? что в программе поменяется?
Новые вопросы