Паскаль
Написать программу которая по введенному четырехзначному числу выводит сумму его цифр.
Спасибо.
Ответы на вопрос
Ответил Аноним
0
// PascalABC.NET 3.2, сборка 1437 от 03.05.2017
// Внимание! Если программа не работает, обновите версию!
begin
var t:=Abs(ReadInteger('n='));
var s:=0;
while t>0 do begin
s:=s+t mod 10;
t:=t div 10
end;
Writeln('Сумма цифр равна ',s)
end.
Пример
n= 3048
Сумма цифр равна 15
Замечание: число не обязательно должно быть четырехзначным и не обязательно положительным.
// Внимание! Если программа не работает, обновите версию!
begin
var t:=Abs(ReadInteger('n='));
var s:=0;
while t>0 do begin
s:=s+t mod 10;
t:=t div 10
end;
Writeln('Сумма цифр равна ',s)
end.
Пример
n= 3048
Сумма цифр равна 15
Замечание: число не обязательно должно быть четырехзначным и не обязательно положительным.
Новые вопросы