Паскаль. написать программу которая, используя признаки делимости, определяет, делится ли число на 6.
var a,c: integer;
begin cls;
randomize;
a:=random (99999+99999+1)-99999;
writeln ( 'исходное числo: ',a);
if (a mod 10) mod 2 =0 then
writeln (' делится на 2')
else
writeln (' не делится на 2');
while a<>0 do
begin
c:= c+(a mod 10);
a:= a div 10;
end;
if c mod 3 = 0 then
writeln (' число делится на 3')
else
writeln (' число не делится на 3');
end.
признак делимости на 6 - это значит, что число делится на 2 и 3. я сделала по отдельности на 2 и 3 ( программа выше). а как это обобщить?
Ответы на вопрос
Ответил Aillianna
0
var
a, c: integer;
begin
randomize;
a := random(99999 + 99999 + 1) - 99999;
writeln('исходное числo: ', a);
while a > 0 do
begin
c := c + a mod 10;
a := a div 10;
end;
if (c mod 3 = 0) and ((a mod 10) mod 2 = 0) then
writeln(' число делится на 6')
else
writeln(' число не делится на 6');
end.
a, c: integer;
begin
randomize;
a := random(99999 + 99999 + 1) - 99999;
writeln('исходное числo: ', a);
while a > 0 do
begin
c := c + a mod 10;
a := a div 10;
end;
if (c mod 3 = 0) and ((a mod 10) mod 2 = 0) then
writeln(' число делится на 6')
else
writeln(' число не делится на 6');
end.
Новые вопросы
Химия,
2 года назад
История,
2 года назад
Биология,
8 лет назад
Информатика,
8 лет назад
Математика,
9 лет назад