Информатика, вопрос задал prozasedman , 9 лет назад

паскаль написать программу которая для прямоугольной целочисленной матрицы 3×4 определяет номер самого левого столбца содержащего только положительные элементы. если такого столбца нет выводится сообщение

Ответы на вопрос

Ответил vladmor
0
const m = 3;
n = 4;
var a: array[1..m, 1..n] of integer;
b: array[1..n] of integer;
i,j,k,maxm:integer;
begin
  for i:=1 to m do begin
    for j:=1 to n do begin
      write('A[',i,',',j,']= ');
      readln (a[i,j]);
      if a[i,j]<=0 then b[j]:=-1;
    end;
  end;
 
  for i:=1 to n do begin
    if b[i]=0  then begin
      writeln('Столбец №',i,' Все положительные');
      break;
     end
     else
      if i=n then writeln('Таких столбцов не было');
    end;
  for i:=1 to m do begin
    for j:=1 to n do write(a[i,j]:5);
    writeln;
  end;
end.

Тестовое решение:
A[1,1]= 7
A[1,2]= 2
A[1,3]= 1
A[1,4]= -9
A[2,1]= -2
A[2,2]= 2
A[2,3]= 4
A[2,4]= 1
A[3,1]= 7
A[3,2]= 2
A[3,3]= 3
A[3,4]= 1
Столбец №2 Все положительные
    7    2    1   -9
   -2    2    4    1
    7    2    3    1



Новые вопросы