Информатика, вопрос задал Kamila1286 , 8 лет назад

паскаль. написать программу для трехзначного числа и вычислить на сколько старший разряд больше младшего.

Ответы на вопрос

Ответил allangarsk
0
var   i, n:integer; b:array[1..3] of integer;begin    write('Type integer: ');    readln(n);    if n<0 then        n:=-n; // уничтожение знака числа     repeat    i:= i + 1;        b[i] := (n mod 10); // вывод последней цифры числа        n:= n div 10; // удаление последней цифры числа    until n=0;    if b[3] > b[2] thenwriteln('Цифра сотен больше десятков ',b[3] - b[2])elsewriteln('Цифра сотен меньше десятков ',b[2] - b[3]);if b[2] > b[1] thenwriteln('Цифра десятков больше единиц ',b[2] - b[1])elsewriteln('Цифра десятков меньше единиц ',b[1] - b[2]);end.
Новые вопросы