Информатика, вопрос задал sonyakharlam , 6 лет назад

Паскаль ((
Написать программу, алгоритм которой находит наименьшее из 5 введённых чисел и возводит его в квадрат до тех пор, пока оно не станет наибольшим.

Ответы на вопрос

Ответил vimmortal2
1

Программа:
Pascal:

var

 num, max, min: real;

begin

 min := MAXINT;  max := -MAXINT;

 writeln('Введите 5 чисел:');

 for var i := 1 to 5 do begin

   readln(num);

   if num < min then min := num;

   if num > max then max := num;

 end;

 writeln('Вы ввели наименьшее число: ', min);

 writeln('Вы ввели наибольшее число: ', max);

 

 while min < max do

   min *= min;

 writeln('Теперь наибольшее число: ', min);

end.

Объяснение:

В начале регистрируем переменные вещественного типа: num, max, min. Далее присваиваем максимальное (допустимое) значение переменной min, минимальное (отрицательное максимальное) - переменной max. Вводятся 5 чисел с клавиатуры и сразу же определяются максимальное и минимальное число. Введённое максимальное, минимальное числа - выводятся. С помощью цикла while возводим число в квадрат, пока оно не станет наибольшим. И минимальное число, которое возводили в квадрат - также выводится.

Результат:

Введите 5 чисел:

10

20

30

40

50

Вы ввели наименьшее число: 10

Вы ввели наибольшее число: 50

Теперь наибольшее число: 100


sonyakharlam: АООАОАОАОА спасибо огромное)))
Новые вопросы