Паскаль
на вход программы поступает кол-во чисел n(1<=n<=1000000) целочисленной последовательности x1,x2,...xn.Напишите программу,которая находит в данной последовательности наибольшее число,в записи которого содержатся цифры 1 и 7 и номер этого числа в последовательности ,а если таких чисел нет ,то вывести 0
Ответы на вопрос
Ответил kornickevg
0
program naib_v_posl_s_1_i_7;
var
n,i,m,x,x1,k:int64;
f1,f7:boolean;
begin
read(n);
m:=0;
for i:=1 to n do
begin
read(x);
x1:=x;
while x1>0 do begin
if (x1 mod 10=1)
then f1:=true
else
if (x1 mod 10=7)
then f7:=true;
x1:=x1 div 10;
end;
if (f1=true)and(f7=true)then
if m<x then
begin
m:=x;
k:=i;
end;
f1:=false;
f7:=false;
end;
if m=0 then
write('no')
else
write(m, ' ',k)
end.
Новые вопросы
Другие предметы,
2 года назад
Русский язык,
2 года назад
Математика,
7 лет назад
Алгебра,
7 лет назад
Литература,
9 лет назад