Информатика, вопрос задал InvoKEr131 , 9 лет назад

("ПАСКАЛЬ" информатика 9 класс) написать ПРОГРАММУ к заданиям (где нужно)
1.Даны радиусы двух кругов R1 и R2.посчитайте площади двух катетов (S:=pi*R1*R2).
посчитайте площадь кольца (S:=S2-S1),при условии ,что S>0. (написать программу на ПАСКАЛЕ)
2.Решите систему уравнений y= (4,если x-1<0) и y= (3,если x-1>=0) написать ПРОГРАММУ НА ПАСКАЛЕ .
3.заданы три числа ,Известно ,что два равны между собой ,а третье отлично от них .
составьте Блок схему и напишите программу нахождение числа ,отличнго от двух других .
РЕБЯТА ,ПРОШУ ПОМОГИТЕ ! БОЛЕЛ И ТЕМ НЕ ЗНАЮ ,ТАК БЫ САМ ВСЁ СДЕЛАЛ. ЕСЛИ ХОТИТЕ БОЛЬШЕ БАЛЛОВ ,НЕ НАДО НА МНЕ "ОТРЫВАТЬСЯ" МНЕ РЕАЛЬНО НУЖНА ПОМОЩЬ . ЗАРАНЕЕ СПАСИБО

Ответы на вопрос

Ответил Maximason
0
Меньше в доту катай, все знать будешь :)
1)
uses crt;
var s,s1,s2,s3,r1,r2:real;
begin
writeln ('Введите радиус первого (маленького) круга:');
read (r1);
writeln ('Введите радиус второго (Большего, чем первый) круга:');
read (r2);
//pi - 3.14
s:=3.14*r1*r2 ;
writeln (s);
//s1 - Площадь первого круга, s2 - второго, s3 - кольца
s1:=3.14*sqr(r1);
s2:=3.14*sqr(r2);
if (s1=0) or (s2=0)
then writeln ('Одна из площадей равна нулю')
else begin s3:=s2-s1 ;  
writeln (s3); end
end.

2)
uses crt;
var x,y,x1,y1 :integer;
begin
writeln ('Введите целое значение x:'); // В программе используются только целые числа !!
read (x);
if (x-1)<0 
then y:=4 
else y:=3;
writeln (y);
end.

3)
uses crt;
var  a,b,c:real ;
begin
writeln ('Последовательно введите 3 числа :');
read (a,b,c);
if (a<>b) and (b<>c) and (a<>c) 
then writeln ('Числа не равны') 
else
if (a=b) and (b=c) and (a=c) 
then writeln ('Числа все равны между собой')
else
if (a=b) and (b<>c) 
then writeln (c) 
else
if (a=c) and (c<>b) 
then writeln (b) 
else
if (b=c) and (c<>a) 
then writeln (a) 
end.

P.s. Писал на Pascal ABC. Блок-схему сделаешь сам, она не сложная. Удачи, инвакир :D
Ответил InvoKEr131
0
в обычном паскале ,как написать ?
Ответил InvoKEr131
0
а всё ,вспомнил
Ответил Maximason
0
<> - неравенство друг другу
Новые вопросы