Информатика, вопрос задал klaropotter , 6 лет назад

Паскаль и только паскаль

Написать программу вычисления стоимости покупки с учетом скидки. Скидка в 5% предоставляется в том случае, если сумма покупки больше 1000 руб., в 10%
- если сумма больше 1500 руб.

Ответы на вопрос

Ответил Puz1koO
1

var

 s:integer;

begin

 write('Введите сумму покупки: '); readln(s);

 if s>1500 then

   writeln('Итог с учётом скидки 10%: ',0.90*s)

     else

       if s>1000 then

         writeln('Итог с учётом скидки 5%: ',0.95*s)

           else

             writeln('Итог: ',s);

end.

Если моё решение вам помогло, отметьте его как лучшее. Спасибо! Удачи!

Новые вопросы