Информатика, вопрос задал maymr , 7 лет назад

Паскаль

Дан возраст человека в годах (0..99 лет). Написать программу, которая называет возраст по-русски. Например: если ввести «1», то программа должна выдать - «1 год», если ввести «22», то программа должна выдать - «22 года», если ввести «45», то программа должна выдать - «45 лет», и так для каждого числа в диапазоне от 0 до 99. Разрешается использовать в программе не более 5 операторов IF.

Ответы на вопрос

Ответил Irremediable
0

Program vozrast;

var x,y : integer;

var godik: string;

Begin

readln(x);

y:=x mod 10;  

if (y=0) or (y>=5) then godik:='Лет';

if (y=1)  then godik:='Год';

if (y>=2) and (y<=4)  then godik:='Года';

if (x>=11) and (x<=14) then godik:='Лет';

writeln(x,' ',godik);

End.

Ответил TheDenFire
0

program gg;

var e:integer;

begin

writeln ('Введите возраст');

read (e);

if e > 99 then

writeln ('Введите возраст до 99 лет')

else if (e mod 10 = 1) and (e <> 11) then

writeln (e,' год')

else if (e >= 2) and (e <= 4) or (e mod 10 = 2) or (e mod 10 = 3) or (e mod 10 = 4) then

writeln (e,' года')

else if (e >= 5) and (e <= 150) then

writeln (e,' лет')

end.

Новые вопросы