Информатика, вопрос задал nastyaorlova15 , 2 года назад

Паскаль!!
Дан массив A(n). Определите количество четных элементов с четными индексами, кратных 7. Выведите на экран исходный массив и полученное количество.


petyaGavrikov: Элементы должны быть кратны 7 или индексы?
nastyaorlova15: Честно , я не знаю.

Ответы на вопрос

Ответил petyaGavrikov
1
const n=10; 
var a:array[1..n] of integer;
i,k:integer; 
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(51);
 write(a[i]:4);
 end;
writeln;
k:=0;
for i:=1 to n do
 if (a[i] mod 2=0)and(a[i] mod 7=0)and(i mod 2=0) then k:=k+1;
writeln('k = ',k);
end.

Пример:
Массив A:
25 29 13 39 9 14 27 16 12 45
k = 1

nastyaorlova15: Спасибоо!!!
petyaGavrikov: Пожалуйста.
Новые вопросы