Информатика, вопрос задал Goblin21 , 2 года назад

Паскаль:через составной оператор Begin....end составить программу, которая вычисляет сумму и среднее арифметическое положительных чисел.
ДАЮ 60 БАЛЛОВ СРОЧНО

Ответы на вопрос

Ответил wensent
1

Ответ:

Program p1;

Var a, i, n, k,z: integer;

Begin

Write('Введите количество чисел: ');

readln(n);

k:=0;

z:=0;

For i:=1 to n do begin

readln (a);

if (a > 0) then k:=k + a;

z:=z + 1;

end;

Writeln('Сумма положительных чисел = ',k);

Writeln('Среднее арифметическое чисел = ',k/z);

End.

Новые вопросы