Информатика, вопрос задал Бублик007 , 10 лет назад

Паскаль АВС! Составить программу,определяющую какая буква слова S(первая или последняя) чаще в нем встречается. 

Ответы на вопрос

Ответил JustPeople
0
VAR
   s: String;
   s1,s2,i: LongInt;
BEGIN
   Read(s);

   s1 := 0; s2 := 0;
   for i := 1 to Length(s) do begin
        if (s[i] = s[1]) then Inc(s1);
        if (s[i] = s[Length(s)]) then Inc(s2);
   end;

     if (s1 > s2) then Write('Первая буква');
     if (s1 < s2) then Write('Последняя буква'); 
     if (s1 = s2) then Write('Равное количество раз.'); 
END.
Новые вопросы