(Паскаль АВС) Напишите программу которая в последовательности натуральных чисел определяет максимальное четное число. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Программа должна вывести одно максимальное четное число!
Ответы на вопрос
Ответил VampireHacker
0
var a:array [0..1010] of longint;
n,max,i:longint;
begin
read (n);
for i:=1 to n do
read (a[i]);
max:=a[1];
for i:=2 to n do
if ((max<a[i]) and (a[i] mod 2=0)) then max:=a[i];
write (max);
end.
n,max,i:longint;
begin
read (n);
for i:=1 to n do
read (a[i]);
max:=a[1];
for i:=2 to n do
if ((max<a[i]) and (a[i] mod 2=0)) then max:=a[i];
write (max);
end.
Новые вопросы
Биология,
2 года назад
Английский язык,
2 года назад
Математика,
9 лет назад
Математика,
10 лет назад