PascalABCnet.Помогите пожалуйста. Задайте массив из 10 элементов с помощью датчика случайных двухзначных положительных чисел. a)Определите количество четных элементов с четными индексами. Выведите на экран исходный массив и полученное количество.
б)Найдите произведение элементов, кратных 5. Выведите на экран исходный массив и полученное произведение.
Ответы на вопрос
Ответил Аноним
0
Var
A:array[1..10] of integer;
k:integer:=0;
Begin
For var i:= 1 to 10 do
Begin
A[i]:=random(10,99);
Write(A[i],' ');
if (i mod 2 = 0)and(A[i] mod 2 = 0) then k+=1;
End;
WriteLn;
WriteLn('Количество четных элементов с четными индексами: ',k);
End.
Var
A:array[1..10] of integer;
P:real:=1;
Begin
For var i:= 1 to 10 do
Begin
A[i]:=random(10,99);
Write(A[i],' ');
if A[i] mod 5 = 0 then P*=A[i];
End;
WriteLn;
WriteLn('Произведение элементов, кратных 5: ',P);
End.
A:array[1..10] of integer;
k:integer:=0;
Begin
For var i:= 1 to 10 do
Begin
A[i]:=random(10,99);
Write(A[i],' ');
if (i mod 2 = 0)and(A[i] mod 2 = 0) then k+=1;
End;
WriteLn;
WriteLn('Количество четных элементов с четными индексами: ',k);
End.
Var
A:array[1..10] of integer;
P:real:=1;
Begin
For var i:= 1 to 10 do
Begin
A[i]:=random(10,99);
Write(A[i],' ');
if A[i] mod 5 = 0 then P*=A[i];
End;
WriteLn;
WriteLn('Произведение элементов, кратных 5: ',P);
End.
Ответил Dennie258
0
Cпасибо братан!!!!!
Новые вопросы