PascalABC.
Составьте программу, которая формирует массив из 15 случайных целых чисел,
каждое из которых находится в диапазоне от -10 до 10 и выводит на экран:
а) Максимальный элемент массива
б) Индекс максимального элемента массива
Ответы на вопрос
Ответил FANTSCR1N
0
program fantscrin;
const n = 15;
var a: array [1..n] of integer;
i,max,max_i:integer;
Begin
for i:=1 to n do
a[i]:= random(21)-10;
for i:=1 to n do
write(a[i], ' ');
max:=a[1];
max_i:=1;
for i:=2 to n do
if (a[i]>max) then
begin
max:=a[i];
max_i:=i;
end;
writeln('');
writeln('Элемент: ', max);
writeln('Индекс: ', max_i);
End.
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад