Информатика, вопрос задал marataglyamov , 8 лет назад

PascalABC.NET
Составить программу, которая печатает true, если точка с координатами (х, у) принадлежит заштрихованной области, и false в противном случае.

Приложения:

Ответы на вопрос

Ответил Аноним
0
PascalABC.NET 3.4.0, сборка 1670 от 23.05.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (x,y):=ReadReal2('Введите x и y через пробел:');
  Writeln(x.Between(-6,-1) and y.Between(2,7) or
      x.Between(-6,-3) and y.Between(-3,2))
end.
Приложения:
Ответил Аноним
0
Границы заштрихованных областей считаются принадлежащими этим областям.
Ответил Аноним
0
Выражение х.Between(a,b) возвращает True, если х принадлежит интервалу [a;b]
Новые вопросы