Информатика, вопрос задал stupikovavlada51 , 7 лет назад

PascalABC.net Пожалуйста, решите используя только: int64, begin, var, for, if, end. Больше добавлять переменных не надо. Даю 98 баллов


Теперь, когда торговля в городе процветает, пришло время подумать о долгосрочных перспективах. В вашу казну недавно пришло n поступлений по k сентиннеалей. Вы решили инвестировать их в промышленность и рассчитываете на ежегодное увеличение своего вложения в m раз.

Рассчитайте, сколько сентиннеалей у вас будет через х лет.

Формат входных данных

В первой строке вводится целое число денежных поступлений n (1 <= n <= 100)

Во второй строке вводится n целых чисел k в строчку, где k - каждое из постулений (1<= k <=10000)

В третьей строке вводятся целые числа x и m - количество лет, в течении которых будет накапливаться итоговая сумма (1<= x <=10), и число раз, в которые будет увеличиваться сумма каждый год (2<= m <=12)

Формат выходных данных

Выводится целое число, равное итоговой сумме накоплений.
Примеры

входные данные
5
2 2 5 4 2
1 2

выходные данные
30

Ответы на вопрос

Ответил ingr
0

var

   n, k, x, m: int64;

begin

   readln(n);

   for x := 1 to n do begin

       read(k);

       n += k-1;

   end;

   readln(x, m);

   writeln(n*x*m);

end.

Ответил MrMiner1
0
А по логике 80
Ответил MrMiner1
0
(10*2*2*2=80)
Ответил MrMiner1
0
Извиняюсь,
2
5 5
3 2
Но сути не меняет
Ответил ingr
0
в моем банке не платят проценты на проценты :) Из вопросе не следует явно что процент нужно считать с нарастающим итогом. Если нужно сделать именно так, пусть автор вопроса напишет и я переделаю программу.
Ответил MrMiner1
0
Я претензий никаких тут и не имею :D
Новые вопросы