Информатика, вопрос задал Vampire1937 , 10 лет назад

Pascal
Выведите все числа на отрезке от a до b, являющиеся полными квадратами.
Примеры:
Входные данные
1
5
Выходные данные
1 4

Ответы на вопрос

Ответил Qeth
0
Var a,b,i:integer;
      x:real;
Begin
Readln(a);
Readln(b);
If a<0 Then a:=1;
For i:=a to b do
 Begin
  x:=sqrt(i);
  If frac(x)=0 Then Write(i,' ');
 End;
End.

Ответил blowberryninja
0
Нечего, бывает)
Ответил Белка199745
0
что такое frac(x)?
Ответил blowberryninja
0
Дробная часть, допустим у вас число 1.5, тогда frac(1.5)=0.5
Новые вопросы