Pascal, составить программу. Пожалуйста, помогите с задачей!
Компьютер запрашивает радиус круга и сторону квадрата. Надо определить, равные ли у них площади (ответ должен иметь вид: «Площади равные»). Если площади не равные, то выводится площадь меньшей фигуры.
Лучшиевсеглавное:
Хелп ми, плиз!
Ответы на вопрос
Ответил asphyxik
1
//s1 - площадь круга, s2 - площадь квадрата
//а - cторона квадрата, r - радиус круга
const pi = 3.14;
var s1,s2,a,r:real;
begin
write('введите а: ');
read(a);
write('введите r: ');
read(r);
s1:=pi*sqr(r);
s2:=sqr(a);
if s1 = s2 then writeln('площади равные')
else
if s1 > s2 then writeln('площадь квадрата: ',s2)
else
if s2 > s1 then writeln('площадь круга: ',s1);
end.
Ответил Аноним
0
Ответ:
var a,r:real;
begin
readln(r);
readln(a);
if (a*a)=(r*r*pi) then
writeln('Площади равны')
else
if (a*a)>(r*r*pi) then
writeln('Площадь круга меньше, она равна: ', r*r*pi)
else
writeln('Площадь квадрата меньше, она равна: ', a*a)
end.
Объяснение:
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Русский язык,
2 года назад
Английский язык,
2 года назад
Алгебра,
8 лет назад
Литература,
8 лет назад