PASCAL . Прошу, срочно надо!!!Составить программу, которая в каждом столбце двумерного массива случайных чисел находит наименьший элемент и записывает его индекс в одномерный массив.
Ответы на вопрос
Ответил mnv1962
7
const
n=10;m=8;
var
a:array[1..n,1..m]of integer;
b:array[1..m]of integer;
i,j,min:integer;
begin
for i:=1 to n do
begin
writeln;
for j:=1 to m do
begin
a[i,j]:=random(100);
write(a[i,j]:4);
end;
end;
writeln;
for j:=1 to m do
begin
min:=a[i,1];
for i:=1 to n do
if a[i,j]<min then
min:=a[i,j];
b[j]:=min;
end;
for i:=1 to m do
write(b[i]:4);
end.
n=10;m=8;
var
a:array[1..n,1..m]of integer;
b:array[1..m]of integer;
i,j,min:integer;
begin
for i:=1 to n do
begin
writeln;
for j:=1 to m do
begin
a[i,j]:=random(100);
write(a[i,j]:4);
end;
end;
writeln;
for j:=1 to m do
begin
min:=a[i,1];
for i:=1 to n do
if a[i,j]<min then
min:=a[i,j];
b[j]:=min;
end;
for i:=1 to m do
write(b[i]:4);
end.
LeraRouch:
Спасибо огромное! Можете еще с этой задачей помочь, пожалуйста? *Составить программу, которая в двумерном массиве случайных чисел элементы всех четных строк делает нулевым.
Новые вопросы
Английский язык,
2 года назад
Русский язык,
2 года назад
Математика,
2 года назад
Русский язык,
2 года назад
Литература,
7 лет назад