Pascal !!!
Помогите составить программу которую выводит вот такую штуку,т.е.:
1)S=2+4+6...+20
2)S=1+2+3...+20
Ответы на вопрос
Ответил Аноним
0
var
i,s:integer;
begin
Write('S=2');
i:=2;
S:=i;
while i<20 do begin
i:=i+2;
Write('+',i);
s:=s+i
end;
Writeln('=',s)
end.
Результат
S=2+4+6+8+10+12+14+16+18+20=110
-------------------------
var
i,s:integer;
begin
Write('S=1');
i:=1;
S:=i;
while i<20 do begin
i:=i+1;
Write('+',i);
s:=s+i
end;
Writeln('=',s)
end.
Результат
S=1+2+3+4+5+6+7+8+9+10+11+12+13+14+15+16+17+18+19+20=210
i,s:integer;
begin
Write('S=2');
i:=2;
S:=i;
while i<20 do begin
i:=i+2;
Write('+',i);
s:=s+i
end;
Writeln('=',s)
end.
Результат
S=2+4+6+8+10+12+14+16+18+20=110
-------------------------
var
i,s:integer;
begin
Write('S=1');
i:=1;
S:=i;
while i<20 do begin
i:=i+1;
Write('+',i);
s:=s+i
end;
Writeln('=',s)
end.
Результат
S=1+2+3+4+5+6+7+8+9+10+11+12+13+14+15+16+17+18+19+20=210
Новые вопросы
Литература,
2 года назад
Математика,
8 лет назад
Обществознание,
9 лет назад
Математика,
9 лет назад