Информатика, вопрос задал BlockBuster , 10 лет назад

Pascal !! Помогите пожалуйста)
Надо составить программу в Паскале, где в двумерном массиве вычисляется количество нулей на главной диагонали.
Завтра сдавать надо( В интернете не нашла ничего толкового..

Ответы на вопрос

Ответил infor5
0
Решение задачи на PascalABC (листинг программы по ссылке, сейчас ее попробую передать)
Ответил Аноним
0
var
   i,j,s:integer;
   a:array[1..10,1..10]of integer;
begin
writeln('Исходный массив:');
for i:=1 to 10 do
  begin
  for j:=1 to 10 do
    begin
    a[i,j]:=random(-10,10);
    if (a[i,j]=0) and (i=j) then s:=s+1;
    write(a[i,j]:3)
    end;
  writeln
  end;
writeln('Число нулей на главной диагонали: ',s)
end.
Новые вопросы