Pascal (Паскаль). Очень прошу помощи
Составить программу сортировки массива методом пузырька НО не использовать for
Только через repeat + использовать flag
Всего в программе должно быть 3 переменных: i,flag,b:integer;
Заранее благодарен, тому кто поможет свяжусь и отблагодарю отдельно
Ответы на вопрос
Ответил Bakalavr
0
program test;
const n = 5;
var i,flag,b:integer;
m:array [1..n] of integer;
begin
b:=1;
for i:=1 to n do
readln(m[i]);
repeat
b:=b+1;
if m[b]<m[b-1] then
begin
flag:=m[b-1];
m[b-1]:=m[b];
m[b]:=flag;
b:=1;
end;
until b=n;
for i:=1 to n do
writeln(i,')',m[i]);
end.
P.S. я использую for только для записи и вывода
const n = 5;
var i,flag,b:integer;
m:array [1..n] of integer;
begin
b:=1;
for i:=1 to n do
readln(m[i]);
repeat
b:=b+1;
if m[b]<m[b-1] then
begin
flag:=m[b-1];
m[b-1]:=m[b];
m[b]:=flag;
b:=1;
end;
until b=n;
for i:=1 to n do
writeln(i,')',m[i]);
end.
P.S. я использую for только для записи и вывода
Новые вопросы
Математика,
2 года назад
Окружающий мир,
2 года назад
Геометрия,
10 лет назад
Математика,
10 лет назад