Информатика, вопрос задал no1uck , 8 лет назад

(Pascal) Нужно составить программу подсчета количества часов, минут и секунд в данном числе суток. Число суток ввести с клавиатуры.

Неправильно считает секунды, в чём ошибка?

var
s,m,h,days: integer;
begin

writeln('Введите кол-во дней');
read(days);
s:=86400;
m:=s div 60;
h:=m div 60;

for var i:=1 to days do
s:=s*days;
m:=m*days;
h:=h*days;

writeln(s,' — секунд в ',days,' днях');
writeln(m,' — минут в ',days,' днях');
writeln(h,' — часов в ',days,' днях');
end.

Ответы на вопрос

Ответил vunderkid
0

Секунды, нужно считать также как минуты и часы без цикла.

Закомментируйте строчку с циклом for var i =1 to days do...

Ответил no1uck
0
про for понял что оно тут не надо вообще, убрал — всё правильно. что значит считать секунды так же как и минуты и часы?
Ответил no1uck
0
а, я понял, спасибо за подсказку.
Ответил vunderkid
0
цикл for действовал только для секунд (Для 1 строки под for)
Новые вопросы