Информатика, вопрос задал 15Konstantin15 , 2 года назад

Pascal.Нужно написать программу на языке Pascal.

Приложения:

Ответы на вопрос

Ответил maxpavlutenkof
1

Var a,x: real;

Begin

readln(a,x);

If x>0 Then

write('y = ',sqrt(x*x+a*a))

Else

write('y = ',sqrt(x*x-a*a));

End.


15Konstantin15: Это точно так?Просто я чутка по другому сделал.Там типо после того,как написал x>0 не надо два случая рассматривать?
maxpavlutenkof: эмм ... что ? при х>0 выводиться первое , в остальных случаях - второе, в чем вопрос ?
15Konstantin15: Всё понял.Благодарю
Новые вопросы