pascal
Ниже записан алгоритм. Сколько существует таких чисел `x`, при вводе которых алгоритм печатает сначала `6`, а потом `27`? Что делает данная программа? Какие это числа? Объясните свои ответы.
var x, a, b: longint;
begin
readln(x);
a:=0; b:=1;
while x>0 do begin
a:=a + 1;
if a mod 2 =0 then
b:=b*(x mod 10);
x:=x div 10;
end;
writeln(a); write(b);
end.
Ответы на вопрос
Ответил denismatora19
0
Ответ:
а не проще на типе интеджер
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Математика,
2 года назад
Геометрия,
2 года назад
Физика,
8 лет назад