PASCAL!!!!!!!!!
Написать программу, выводящую номер этажа, где расположена квартира, если известно, что в этажном доме один подъезд, на четных этажах по 7 квартир, на нечетных – 5, при этом на первом этаже квартир нет. При входе в дом вводится номер квартиры. В случае ошибочного ввода номера квартиры, программа должна сообщать об этом.
Ответы на вопрос
Ответил Kostya1977
0
a - номер квартиры, начиная с 1
n - этаж
C:
n = 2*((a-1)/12)+2+((а-1)%12)/7
Pascal:
n := 2*((a-1) div 12)+2+((a-1) mod 12) div 7
выражение в одну строку
% это остаток от деления
a и n переменные целого типа, подразумевается, что происходит автоматическое округление при делении в меньшую сторону
n - этаж
C:
n = 2*((a-1)/12)+2+((а-1)%12)/7
Pascal:
n := 2*((a-1) div 12)+2+((a-1) mod 12) div 7
выражение в одну строку
% это остаток от деления
a и n переменные целого типа, подразумевается, что происходит автоматическое округление при делении в меньшую сторону
Ответил polinKa6262
0
Program two;
var a,n:integer;
begin
writeln('Введите номер квартиры ',a);
readln(n);
n := 2*((a-1) div 12)+2+((a-1) mod 12) div 7;
writeln('этаж ' , n)
end.
var a,n:integer;
begin
writeln('Введите номер квартиры ',a);
readln(n);
n := 2*((a-1) div 12)+2+((a-1) mod 12) div 7;
writeln('этаж ' , n)
end.
Ответил Kostya1977
0
ошибка в readln
Ответил Kostya1977
0
квартира в переменной a
Ответил Kostya1977
0
и сделайте проверку: номер квартиры больше 0
Ответил polinKa6262
0
жму руку,спасибо огромное
Новые вопросы