Pascal. Написать программу, которая позволяет транспонировать матрицу. Размерность вводится с клавиатуры, значения случайные числа от -10 до 10.
Ответы на вопрос
Ответил izzyakrueger
0
Ответ:
program mtr1;
const N=10;
type iint:1..10;
matrix: array [iint,iint] of integer;
var a: matrix;
i,j: iint;
m:iint;
v:integer;
begin
readln (m);
randomize;
(* заполнение матрицы *)
for i:=1 to m do
for j:=1 to m do
a[i,j] := random(21)-10;
for i:=1 to m do
for j:=i to m do
begin
if i=j then
continue;
v:= a[i,j];
a[i,j] := a[j,i];
a[j,i] := v;
end;
for i:=1 m do
begin
for j:=1 to m do
write(a[i,j],' ');
writeln;
end;
end.
Объяснение:
Новые вопросы
Английский язык,
2 года назад
Русский язык,
2 года назад
Математика,
7 лет назад
Геометрия,
7 лет назад
Музыка,
8 лет назад