Pascal.
Дан одномерный массив. Написать программу, которая находит значение
максимального элемента и заменяет его на значение произведения элементов
(остальных) массива (второй массив не использовать). Программа выводит
исходные данные и измененный массив.
Ответы на вопрос
Ответ:
program n1;
uses crt;
var aw:array[1..10] of integer;
i,w,g:integer;
begin
g:=0;
w:=10;
for i:=0+1 to w do begin
aw[i]:=random(100);
write(aw[i]:6);
end;
writeln();
write('Чот');
for i:=0+1 to w do begin
if aw[i] mod 2 = 0 then g:=g+1; end; write('Всего чотных чисел ',g);
writeln();
write('Не чот');
g:=0;
for i:=0+1 to w do begin
if aw[i] mod 2 > 0 then g:=g+1;end; write('
Ответ:
Pascal
const
n=10;
var
a : array [0..n] of double;
i, ind : integer;
m, ma : double;
begin
randomize;
writeln('Массив A');
for i:=0 to n-1 do begin
a[i] := random(20);
write(a[i]:0:0, ' ');
end;
writeln();
m:=1;
ind:=0;
ma:=0;
for i:=0 to n-1 do begin
m:=m*a[i];
if a[i] > ma then begin
ma:=a[i];
ind:=i;
end;
end;
a[ind]:= m/ma;
for i:=0 to n-1 do
write(a[i]:0:0,' ')
end.
