Pascal
Дан массив из 50 элементов. Каждый элемент может принимать целочисленное значение от -500 до 500. Напишите программу, которая определяет на сколько число положительных элементов массива больше, чем число отрицательных, и выведите найденное значение. Гарантируется, что в исходном массиве есть и отрицательные, и положительные элементы, и положительных элементов больше.
Ответы на вопрос
Ответ:
Объяснение:
program ArrayOf50;
const
ArraySize = 50; {Определяем размен массива}
var
x: array[1..ArraySize] of integer;
i, PosCount, NegCount : integer;
begin
PosCount :=0; NegCount :=0; {Устанавливаем счетчики пол. и отр. чисел}
for i:=1 to ArraySize do begin {Цикл ввода данных}
Write('Input ', i, '-th element of array: ');
ReadLn(x[i]);
end;
for i:=1 to ArraySize do begin {Цикл обработки данных}
if x[i] > 0 then PosCount := PosCount+1; {считаем положительные}
if x[i] < 0 then NegCount := NegCount+1; {считаем отрицательные, нули в расчет не берутся!}
end;
Writeln('There are ', PosCount, ' positive numbers.');
Writeln('This is ', PosCount - NegCount, ' more than negatives');
end.