Информатика, вопрос задал hh2020 , 2 года назад

PASCAL

Дан целочисленный массив из 20 элементов, из промежутка [-100; 50]. Напишите программу
позволяющую найти и вывести минимальное значение среди положительных элементов
массива, кратных 5 Если в исходном массиве нет элемента, значение которого положительно
и делится на 5, то вывести сообщение «Не найдено».

Ответы на вопрос

Ответил Alpixx
0

var  

i, answer: integer;

arr: array[-100..50] of integer;

begin

answer := -1;

for i:= 0 to 19 do

begin

 read(arr[i]);

 if ((arr[i] > 0) and (arr[i] mod 5 = 0) and (arr[i] > answer)) then answer := arr[i];

end;

   if answer = -1 then writeln('Не найдено')

   else writeln(answer);

end.

Новые вопросы