Pascal ABC. Составьте программу, которая рисует деталь в виде кольца внешним радиусом 150 и внутренним радиусом 50, в котором вырезаны отверстия радиусом 30. Их центры находятся на расстоянии 100 от центра кольца (число отверстий n вводится с клавиатуры). 2<n<8
Ответы на вопрос
program Risovalka;
uses crt,graphABC;
var xc,yc,r1,r2,rc,ro,n,i,x,y:integer;
a:real;
begin repeatwrite('ykashi shislo otverstii ot 5 do 10 n=');
read(n);
until n in [5..10];
clrscr; hidecursor;
xc:=windowwidth div 2;
yc:=windowheight div 2;
r1:=40;
r2:=120;
rc:=100; ro:=30;
a:=2*pi/n;
circle(xc,yc,r2);
circle(xc,yc,r1);
for i:=1 to n do begin x:=xc+round(rc*cos(a*i));
y:=yc-round(rc*sin(a*i));
circle(x,y,ro);
end.