Pascal ABC
Напишите программу, которая сортирует массив и выводит все элементы массива, которые встречаются ровно K раз.
Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 . В третьей строке записано натуральное число K .
Выходные данные
Программа должна вывести все элементы массива, которые встречаются ровно K раз, в порядке возрастания, разделив их пробелами. Если таких элементов нет, программа должна вывести число 0.
Примеры
входные данные
6
1 2 1 2 1 3
2
выходные данные
2
Ответы на вопрос
Ответил Mapleshade02
0
var
begin
c:=0;
Read(n);
Read(k);
For i:=1 to n do read(a[i]);
For i:=1 to n-1 do
For j:=n-1 downto i do
If a[j]>a[j+1] then begin
C:= A[j];
a[j]:=a[j+1];
A[j+1]:=c;
End;
For i:=1 to n do begin
For j:=I to n do
If a[i]=a[j] then c:=c+1;
If c=k then write(a[i],` `);
c:=0;
End;
End.
Ответил Mapleshade02
0
С телефона пишу, но порога должна работать
Ответил Mapleshade02
0
Прога*
Ответил skokov2001
0
Надо через массив и вложенный цикл
Ответил Mapleshade02
0
В новый массив числа записать?
Ответил skokov2001
0
Дописал прогу спасибо за код
Новые вопросы