PASCAL ABC Напишите программу, которая получает с клавиатуры натуральное число и вычисляет целый квадратный корень из него – наибольшее число, квадрат которого не больше данного числа.
ВНИМАНИЕ!!! НЕОБХОДИМО РЕШИТЬ ЧЕРЕЗ ЦИКЛ С ПОСТУСЛОВИЕМ, ОТВЕТ ТИПА
var
n, s: Integer;
begin
Write ('Введите натуральное число: ');
Read (n);
s := trunc (sqrt (n));
Writeln ('Целый квадратный корень из ' + IntToStr (n) + ' = ' + IntToStr (s));
Readln;
end;
ПРИНИМАТЬСЯ НЕ БУДЕТ
На этот вопрос еще никто не ответил. Напишите свой ответ или воспользуйтесь поиском:
Новые вопросы