Информатика, вопрос задал BaKeRiA , 7 лет назад

Pascal ABC:Дано натуральное число.Напишите программу, которая проверяет, является ли оно трёхзначным и кратна ли 7 сумма его цифр.

Ответы на вопрос

Ответил laim207p3xrsk
0

Pascal p1;

Var a,b,c,d:integer;

Begin

Readln(a);

B:=a mod 10;

C:= a div 10 mod 10;

D:=a mod 100 div 10;

If (a>=100) and (a<1000) then writeln ('трехзначное')

else writeln('не трехзначное');

If b+c+d mod 7=0 then writeln ('сумма кратна семи')

else writeln ('сумма не кратна семи');

End.

Сложненько, так как не особо поняла, что от нас хотят, извините, если не так

Ответил dDeVoChKa
0
Я просто Вас УМОЛЯЮ! Спасите! https://znanija.com/task/31315308
Новые вопросы