Парни помогите :D
нужно написать программу на Паскале
что бы она вычисляла сумму значения элементов трехмерного массива тип LongIn, 2x2x2 (вроде бы,короче че то 2 на 2 :D)
Ответы на вопрос
Ответил pacixor
0
Если будет ошибка на строчке:
write('Введите A[' + IntToStr(i) + ',' + IntToStr(j) + ',' + IntToStr(k) + '] = ');
можешь просто убрать ее.
Она может не работать из за разных версий Pascal-я, т.к. не везде есть IntToStr.
--------------------------------------------------------------------
var
A: array [1..2,1..2,1..2] of longint;
i, j, k: byte;
sum: longint;
begin
for i := 1 to 2 do
for j := 1 to 2 do
for k := 1 to 2 do
begin
write('Введите A[' + IntToStr(i) + ',' + IntToStr(j) + ',' + IntToStr(k) + '] = ');
ReadLn(A[i, j, k]);
end;
sum := 0;
for i := 1 to 2 do
for j := 1 to 2 do
for k := 1 to 2 do
sum := sum + A[i, j, k];
writeln('Сумма всех элементов трехмерного массива = ', sum);
readln;
end.
write('Введите A[' + IntToStr(i) + ',' + IntToStr(j) + ',' + IntToStr(k) + '] = ');
можешь просто убрать ее.
Она может не работать из за разных версий Pascal-я, т.к. не везде есть IntToStr.
--------------------------------------------------------------------
var
A: array [1..2,1..2,1..2] of longint;
i, j, k: byte;
sum: longint;
begin
for i := 1 to 2 do
for j := 1 to 2 do
for k := 1 to 2 do
begin
write('Введите A[' + IntToStr(i) + ',' + IntToStr(j) + ',' + IntToStr(k) + '] = ');
ReadLn(A[i, j, k]);
end;
sum := 0;
for i := 1 to 2 do
for j := 1 to 2 do
for k := 1 to 2 do
sum := sum + A[i, j, k];
writeln('Сумма всех элементов трехмерного массива = ', sum);
readln;
end.
Приложения:

Новые вопросы